Jump to content


Photo

Radiator Fan Motor Repair

radiator fan fan motor

  • Please log in to reply
No replies to this topic

#1 Wardljc

Wardljc

    Mostly Harmless

  • Members
  • PipPip
  • 10 posts

Posted 05 April 2019 - 08:31 PM

Radiator Fan Motor

Toyota: 16363-74030

Denso: 162500-7720

21ned7c.jpg

My car started overheating when I left it idling.  As long as I was moving, it was fine.  The radiator fan motor was not coming on.  It would work intermittently at first which made tracing the problem frustrating.  I finally was able to trace the problem to the radiator fan motor. 

Finding an exact motor in the U.S. was equally frustrating.  It was available at the Toyota dealership for around $250.  Although I ended up ordering a new motor from Amazon Japan for around $100 including shipping to the US, I thought I would see if the original motor was repairable

 

The motor was surprisingly simple to repair.  It came apart easily.  The brushes had become dirty and were no longer sliding in their housing.  I just cleaned them up and put it back together.

 

To get to the motor, you must remove the fan shroud assembly.

Disconnect the fan motor on the right side of the shroud (the side closest to the battery).

Remove the 3 10mm-head bolts, two at the top and one in the center at the bottom.

Carefully squeeze the plastic prongs of the oxygen sensor connector from the inside of the shroud to remove it and let it hang free, no need to disconnect the plug.

Slide the clamp on the upper radiator hose from the radiator side to the middle of the hose so you can pull the hose off of the radiator.  Little or no coolant will come out if the car is level.

Pull the fan assembly up and out.

zvao9s.jpg

Remove the motor from the shroud.

Remove the 8mm-head nut holding the plastic blades to the end of the motor shaft.

Remove the cable from the shroud by bending up the metal cable support tabs.

Slide the disconnect off of the support bracket.

Remove the 3 Phillips-head screws holding the motor to the metal shroud.

 

Opening the motor.

There are 6 small metal tabs that hold the end of the motor to the motor housing. These are easy to pry up with a small flat head screwdriver. Use the same screwdriver to pry up the end of the motor using the small slot by the wire grommet.  You can try tapping the end plate off if it doesn't pop off immediately.

 

ezljyc.jpg

 

Clean the inside of the motor with Brake Cleaner.  Get the brushes to slide in their housings.  They seem to be made so they can be pushed outboard in the housing and be jammed so they will be out of the way when the motor is reassembled.  They spring back by tapping on the endplate.  I buffed the copper on the commutator too. 

Lubricate the end of the shaft and the bushing and reassemble.   Be sure you hear the brushes spring back when tapping the end plate tabs back onto the housing.

I measured between 35-40 Ohms on the connector.it will vary when rotating the shaft.

 

29hiea.jpg

Brushes cleaned and pressed back in housing before reassembly.  They will pop back when you tap the end plate.

 

v7h0n5.jpg

ina7w2.jpg






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users