Jump to content


Photo

Sera In The Netherlands


  • Please log in to reply
113 replies to this topic

#106 Toyoloog

Toyoloog

    Competent

  • Members
  • PipPipPipPipPipPip
  • 368 posts

Posted 29 May 2018 - 11:15 AM

Right, a new radiator cap with a slightly higher pressure seemd to have solved the coolant issue. Car still running rich though so I'd figured I check the fuel pressure regulator as I've already checked and cleaned the injectors. Hooked up my pressure tester and with just the pump running I got about 30 PSI which is way to low for no vacuum scenario. Started the engine and pressures were up to about 40 PSI to 30 PSI depending on the vacuum created. Stopped engine and now pressure with just pump running was 36PSI... Eventuelly I tapped the fuel pressure regulator and the pressure shot up to a healthy 42 PSI. Tapped it some more and pressure dropped again. This leaves me to believe the FPR is on it's way out, especially since the system will not hold pressure after the engine/pump has stopped (which it should if it's anything like the 4A-GE). I'll have a look for another one and try that, hopefully that will solve the rich conditions and after-fire when changing gears.



#107 Toyoloog

Toyoloog

    Competent

  • Members
  • PipPipPipPipPipPip
  • 368 posts

Posted 31 May 2018 - 11:42 AM

Picked up another fuel pressure regulator today from a 4E-FTE but it has the same part number. Installed it and tested the pressures: All according to the manual this time. A rest-drive revealed that the after-fire is gone, although the revs still dip when going from cruise to idle (after wich it does pick up a bit but still feels like it's about to stall for a second). Going to try and reset the ECU and adjust idle speed again and see if that makes any difference.



#108 Toyoloog

Toyoloog

    Competent

  • Members
  • PipPipPipPipPipPip
  • 368 posts

Posted 13 August 2018 - 07:40 AM

Did some more to the Sera yesterday, installed new front brakes (Astra G discs 280mm, spigot rings to reduce diameter from 60mm to 54mm, AE111 twinpod calipers with ST202 non-superstrut carriers) and a new master brake cylinder. Original was 13/16 (non-ABS model), now a 15/16 version from an ST202. Noticed the front tyres cracked so off later today to have those replaced as well. Then it's back to some bits and bobs to the interior and exterior again.



#109 Toyoloog

Toyoloog

    Competent

  • Members
  • PipPipPipPipPipPip
  • 368 posts

Posted 22 September 2018 - 08:10 AM

Sera passed it's Dutch equivalent of MOT again last week!
Apart from some new wiper blades no issues whatsoever. This was including the front twinpod brakes with 15/16 MBC and LED bulbs in both headlights and brights.
Very pleased I must say!
Checked cylinder leaktest as well. Some slight leaking via the piston-rings on cylinder #3 (10% vs 5% on the other 3 cylinders) but nothing mayor and probably not worth checking into that further.



#110 Toyoloog

Toyoloog

    Competent

  • Members
  • PipPipPipPipPipPip
  • 368 posts

Posted 30 April 2019 - 08:35 AM

ell, this morning I finally had my A/C pressure tested and refilled. Still have the R12 compressor but had it refilled with R134a, 0,55kg to be exact. Heard the compressor actually kick in this time so I know the pressure switches are working. Temperature went to 8 degC within 2 minutes so that should work fine. Let's hope it'll last!



#111 Toyoloog

Toyoloog

    Competent

  • Members
  • PipPipPipPipPipPip
  • 368 posts

Posted 01 June 2019 - 04:53 PM

And the A/C is empty again... At least the compressor does not kick in so I suspect it's the pressure switch again failing to register any pressure in the LP side of the system.
On another side not, started with the metal frame between the roof glass and the drop-down glass as it is starting to rust on a few spots. Got all the 3 screws and the bolt out and freed up the side next to the door sill but the sections attached to the glass seem impossible to move. Therefore bolted everything back for now and ordered a windscreen repair kit with one of those cutters with a pull handle. Hopefully that will help minimizing the seal between the metal and the glass. Sanding in place is not the best option here as the rust shows around also in the rain "gutter" so to say. Once the metal is out it's of sandblasting it clean and then some new epoxy paint to make it neat again.



#112 Toyoloog

Toyoloog

    Competent

  • Members
  • PipPipPipPipPipPip
  • 368 posts

Posted 01 July 2019 - 07:09 AM

Got the parts in along with some parts from Japan. Now have the rear boor section of what looks like the G5 spoiler and some SLSS tweeter pods, unfortunately one broke but the other one is good for a 3D scan so those will be available for printing soon I hope. Those came also with a center speaker but as expected the speaker itself was shot so still on the lookout for one that actually fits the housing.

On the A/C side of things, current low pressure only 6 PSI so definitely got a leak somewhere, now to pressurise the system and remove the radiator (pretty sure it's on the A/C radiator side of things but could not find anything on the front side).
 

To be continued!



#113 Toyoloog

Toyoloog

    Competent

  • Members
  • PipPipPipPipPipPip
  • 368 posts

Posted 22 September 2019 - 08:19 AM

Still trying to source an A/C compressor seal kit but so far only found bits for them. Maybe it's just the mechanical seal and it's sufficient to fix the compressor.

On another not, I was given a ultra-racing under brace by a mate of mine tho has it on it's starlet EP82 but due to exhaust mods couldn't get it to fit any more. I'll see if it will fir the Sera and post back here.

Smaller radiator has also arrived, just need the time to fit it and see if that helps with the overflowing issue (no exhaust fumes in coolant, I checked) which I suspect are because of the way too big radiator I currently run. (about 7.5 litres of coolant at the moment)

I've also made it my mission to resolve the leaking distributor, a new one was sourced from ebay but unfortunately upon taking it to bits the 2 magnets on the inside were crumbled to bits and are therefore unservicable. I did note that the 3S-GE, 3S-GTE, 5S-FE, 4A-FE lean-burn, 4A-GE 20V use the same internal pickup so I'm hoping to source one of those distributors to see if I can repair my spare dizzy. If so repair kits will be made available of course.

Then there is the "issue" with the engine. I've noticed since I have the Sera (even with the 1.3 engine in) the idle RPM dips when the gas pedal suddenly gets released. Something with the fact that the throttle closes too sudden and the ECU needs some time to adjust the mixture to the new air volume. With the 1.3 engine and auto-box this would occasionally even stall the engine, with the 5efhe and manaul box the RPM can drop to 500 which makes it almost stall. This also happens on coasting and then pressing the clutch pedal. Slowing down on the brakes before de-clutching helps to minimize this. I'm not sure if other Sera owners have the same issue but I'm now trying to install a dash pot from a 2E-E to make the last few degrees of the TB closing a bit slower. This was a trick to reduce emissions as well on the 4A-GE 16V so I expect it to work wonders on the 5E-FHE unless someone has a other suggestion?



#114 Ga tom

Ga tom

    Poor

  • Super Special Members
  • PipPipPip
  • 26 posts

Posted 28 September 2019 - 02:48 PM

Toyoloog there is a company in uk that refurbished AC compressors Antony Thorley as done a post about them ,its WWW.Coldlink.co.uk the new gas R134a is not compatable with the R12 seals




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users